Commit ed54935b authored by Per Cederqvist's avatar Per Cederqvist
Browse files

($(srcdir)/15.exp): Use $(PYTHON) instead of python. Use the

	HAVE_PYTHON Automake conditional.
($(srcdir)/19.exp): Ditto.
parent f6edc13d
# $Id: Makefile.am,v 1.30 2003/08/13 13:29:35 ceder Exp $
# $Id: Makefile.am,v 1.31 2003/08/13 20:38:31 ceder Exp $
# Copyright (C) 2000-2002 Lysator Academic Computer Association.
#
# This file is part of the LysKOM server.
......@@ -30,15 +30,21 @@ check_DATA = $(srcdir)/15.exp $(srcdir)/19.exp
$(srcdir)/15.exp: $(srcdir)/gen-15.py
$(RM) $@ $@.tmp
if python $^ > $@.tmp; then echo ok; \
else echo fail;echo 'unsupported "15.exp needs python"' > $@.tmp; fi
if HAVE_PYTHON
$(PYTHON) $^ > $@.tmp
else
echo 'unsupported "15.exp needs python"' > $@.tmp
endif
chmod 444 $@.tmp
mv -f $@.tmp $@
$(srcdir)/19.exp: $(srcdir)/gen-19.py
$(RM) $@ $@.tmp
if python $^ > $@.tmp; then echo ok; \
else echo fail;echo 'unsupported "19.exp needs python"' > $@.tmp; fi
if HAVE_PYTHON
$(PYTHON) $^ > $@.tmp
else
echo 'unsupported "19.exp needs python"' > $@.tmp
endif
chmod 444 $@.tmp
mv -f $@.tmp $@
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment