Commit d4a6c066 authored by Niels Möller's avatar Niels Möller

Check for krb5_verify_user_lrealm, and disable

kerberos support if not found.

Rev: ChangeLog:1.815
Rev: configure.ac:1.57
parent ca226995
2004-11-09 Niels Mller <niels@s3.kth.se>
* src/lsh-krb-checkpw.c (main): Noted that the current code seems
to work only with Heimdal, not MIT kerberos.
* configure.ac: Check for krb5_verify_user_lrealm, and disable
kerberos support if not found.
2004-11-09 Niels Mller <nisse@lysator.liu.se>
* doc/lsh.texinfo: Set UPDATED-FOR to 2.0.
......
......@@ -474,7 +474,9 @@ if test x$enable_kerberos = xyes; then
LSH_CHECK_KRB_LIB(resolv, dn_expand)
LSH_CHECK_KRB_LIB(des, des_cbc_encrypt)
LSH_CHECK_KRB_LIB(asn1, der_get_octet_string)
LSH_CHECK_KRB_LIB(krb5, krb5_cc_gen_new,, [enable_kerberos=no])
# Check for krb5_cc_gen_new too?
# krb5_verify_user_lrealm seems to be unique to heimdal
LSH_CHECK_KRB_LIB(krb5, krb5_verify_user_lrealm,, [enable_kerberos=no])
fi
AH_TEMPLATE([WITH_KERBEROS], [For kerberos])
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment