changelog 9.28 KB
Newer Older
Ulrik Haugen's avatar
Ulrik Haugen committed
1
lyskom-elisp-client (0.48+git.20180410.1d357c67-3) unstable; urgency=medium
Joel Rosdahl's avatar
Joel Rosdahl committed
2

Ulrik Haugen's avatar
Ulrik Haugen committed
3
  * Source-only upload.
Joel Rosdahl's avatar
Joel Rosdahl committed
4

Ulrik Haugen's avatar
Ulrik Haugen committed
5
 -- Joel Rosdahl <joel@debian.org>  Sat, 03 Aug 2019 11:31:15 +0200
Joel Rosdahl's avatar
Joel Rosdahl committed
6

Ulrik Haugen's avatar
Ulrik Haugen committed
7
lyskom-elisp-client (0.48+git.20180410.1d357c67-2) unstable; urgency=medium
Joel Rosdahl's avatar
Joel Rosdahl committed
8

Ulrik Haugen's avatar
Ulrik Haugen committed
9
  * Check whether Emacs flavor exists (closes: #931168)
Joel Rosdahl's avatar
Joel Rosdahl committed
10

Ulrik Haugen's avatar
Ulrik Haugen committed
11
 -- Joel Rosdahl <joel@debian.org>  Fri, 12 Jul 2019 23:37:58 +0200
Joel Rosdahl's avatar
Joel Rosdahl committed
12

Ulrik Haugen's avatar
Ulrik Haugen committed
13
lyskom-elisp-client (0.48+git.20180410.1d357c67-1) unstable; urgency=medium
Joel Rosdahl's avatar
Joel Rosdahl committed
14

Ulrik Haugen's avatar
Ulrik Haugen committed
15 16 17 18
  * Handle unversioned Emacs flavor "emacs" (closes: #930784)
  * Bump Standards-Version to 4.3.0 with no changes
  * New upstream release 0.48+git.20180410.1d357c67
  * Bump debhelper to version 12
Joel Rosdahl's avatar
Joel Rosdahl committed
19

Ulrik Haugen's avatar
Ulrik Haugen committed
20
 -- Joel Rosdahl <joel@debian.org>  Thu, 20 Jun 2019 20:50:40 +0200
Joel Rosdahl's avatar
Joel Rosdahl committed
21

Ulrik Haugen's avatar
Ulrik Haugen committed
22
lyskom-elisp-client (0.48+git.20160707.372be663-1) unstable; urgency=medium
Joel Rosdahl's avatar
Joel Rosdahl committed
23

Ulrik Haugen's avatar
Ulrik Haugen committed
24 25 26 27
  * New upstream release 0.48+git.20160707.372be663
  * Bump Standards-Version to 3.9.8 (no changes)
  * Add Brazilian Portuguese translation (closes: #831300)
  * Hardcode package version in debian/rules since it's no longer available
Joel Rosdahl's avatar
Joel Rosdahl committed
28

Ulrik Haugen's avatar
Ulrik Haugen committed
29
 -- Joel Rosdahl <joel@debian.org>  Sun, 28 Aug 2016 17:30:44 +0200
Joel Rosdahl's avatar
Joel Rosdahl committed
30

Ulrik Haugen's avatar
Ulrik Haugen committed
31
lyskom-elisp-client (0.48+git.20140815.afa49c26-3) unstable; urgency=medium
Joel Rosdahl's avatar
Joel Rosdahl committed
32

Ulrik Haugen's avatar
Ulrik Haugen committed
33
  * Compensate for behavioral change in grep 2.23 (closes: #817772)
Joel Rosdahl's avatar
Joel Rosdahl committed
34

Ulrik Haugen's avatar
Ulrik Haugen committed
35
 -- Joel Rosdahl <joel@debian.org>  Thu, 17 Mar 2016 08:17:20 +0100
Joel Rosdahl's avatar
Joel Rosdahl committed
36

Ulrik Haugen's avatar
Ulrik Haugen committed
37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278
lyskom-elisp-client (0.48+git.20140815.afa49c26-2) unstable; urgency=medium

  * Make build reproducible (closes: #777487)
  * Bump Standards-Version to 3.9.6 (no changes)

 -- Joel Rosdahl <joel@debian.org>  Sun, 15 Feb 2015 14:30:54 +0100

lyskom-elisp-client (0.48+git.20140815.afa49c26-1) unstable; urgency=medium

  * New upstream release 0.48+git.20140815.afa49c26
  * Remove obsolete patch
  * Get upstream version automatically

 -- Joel Rosdahl <joel@debian.org>  Fri, 15 Aug 2014 17:41:02 +0200

lyskom-elisp-client (0.48+git.20140704.9f19be20-2) unstable; urgency=medium

  * Remove obsolete conflict with emacs21 (closes: #665302)
  * Add Italian translation (closes: #729794)

 -- Joel Rosdahl <joel@debian.org>  Thu, 10 Jul 2014 15:05:03 +0200

lyskom-elisp-client (0.48+git.20140704.9f19be20-1) unstable; urgency=low

  * New snapshot from upstream repository
  * Update patch with new filename
  * Update version
  * Remove dependency on emacs23 (closes: #754022)
  * Bump Standards-Version to 3.9.5
  * Use debhelper compat level 8
  * Add description to xemacs_parse_time_fix.patch
  * Use dh_prep instead of "dh_clean -k"
  * Add recommended build-arch and build-indep targets
  * Add watch file saying that no watched URL is possible
  * Remove obsolete Lintian override
  * Update URL of upstream sources

 -- Joel Rosdahl <joel@debian.org>  Thu, 10 Jul 2014 13:36:42 +0200

lyskom-elisp-client (0.48+cvs20100715-3) unstable; urgency=low

  * Added Danish translation. Closes: #627822.
  * Updated to Standards-Version to 3.9.2 (no changes needed).

 -- Joel Rosdahl <joel@debian.org>  Sun, 29 May 2011 12:11:38 +0200

lyskom-elisp-client (0.48+cvs20100715-2) unstable; urgency=low

  * Fix (suggested by Marcus Comstedt) for "Symbol's function definition
    is void: parse-time-string" error in XEmacs.
  * Updated to Standards-Version 3.9.1 (no changes needed).

 -- Joel Rosdahl <joel@debian.org>  Wed, 04 Aug 2010 18:07:42 +0200

lyskom-elisp-client (0.48+cvs20100715-1) unstable; urgency=low

  * New version from upstream CVS with Emacs 22, 23 and 24 compatibility
    improvements. Emacs 21 support dropped.
  * Added Spanish translation from Ricardo Fraile. Closes: #581313.
  * Bumped Standards-Version to 3.9.0 with no changes.

 -- Joel Rosdahl <joel@debian.org>  Thu, 15 Jul 2010 11:00:16 +0200

lyskom-elisp-client (0.48-14) unstable; urgency=low

  * Switch to dpkg-source 3.0 (quilt) format.
  * Depend on emacs23 instead of emacs22.
  * Bumped Standards-Version to 3.8.4 with no changes.

 -- Joel Rosdahl <joel@debian.org>  Sun, 21 Feb 2010 15:17:11 +0100

lyskom-elisp-client (0.48-13) unstable; urgency=low

  * Added Russian translation from Yuri Kozlov. Closes: #549177.
  * Added -e flag to postinst and prerm scripts.
  * Clarified that the license is GPL2+.
  * Switched patch manager from dpatch to quilt.
  * Added README.source.
  * Updated to Standards-Version 3.8.3.

 -- Joel Rosdahl <joel@debian.org>  Wed, 14 Oct 2009 19:21:16 +0200

lyskom-elisp-client (0.48-12) unstable; urgency=low

  * Added Dutch translation from Bart Cornelis. Closes: #449399.
  * Depend on emacs22 instead of emacs21.
  * Added Lintian override for
    making-assumptions-about-interfaces-in-templates; Lintian seems to
    misinterpret the template somehow.

 -- Joel Rosdahl <joel@debian.org>  Mon, 03 Dec 2007 19:27:50 +0100

lyskom-elisp-client (0.48-11) unstable; urgency=low

  * Added Portuguese translation by Américo Monteiro. Closes: #435505.

 -- Joel Rosdahl <joel@debian.org>  Sat, 04 Aug 2007 23:00:09 +0200

lyskom-elisp-client (0.48-10) unstable; urgency=low

  * Removed DH_COMPAT variable from debian/rules to fix Lintian warning.
  * Use debhelper compatibility 5.
  * Bumped build dependency on debhelper.

 -- Joel Rosdahl <joel@debian.org>  Sun, 22 Apr 2007 22:11:12 +0200

lyskom-elisp-client (0.48-9) unstable; urgency=low

  * Added German translation from Helge Kreutzmann. Closes: #411511.

 -- Joel Rosdahl <joel@debian.org>  Mon, 26 Feb 2007 20:19:32 +0100

lyskom-elisp-client (0.48-8) unstable; urgency=low

  * Updated Japanese translation from Hideki Yamane. Closes: #400035.

 -- Joel Rosdahl <joel@debian.org>  Mon, 29 Jan 2007 20:31:20 +0100

lyskom-elisp-client (0.48-7) unstable; urgency=high

  * Don't remove all *.el files in /usr/share/$FLAVOR/site-lisp.
    Closes: bug#381718, which is has severity critical; hence urgency=high.

 -- Joel Rosdahl <joel@debian.org>  Sun,  6 Aug 2006 19:24:37 +0000

lyskom-elisp-client (0.48-6) unstable; urgency=low

  * Updated Czech translation with patch from Miroslav Kure.
    Closes: bug#370732.
  * Updated to Standards-Version 3.7.2.
  * Made debhelper and dpatch dependencies ordinary Build-Depends
    instead of Build-Depends-Indep.

 -- Joel Rosdahl <joel@debian.org>  Tue,  6 Jun 2006 20:57:12 +0200

lyskom-elisp-client (0.48-5) unstable; urgency=low

  * Added Swedish translation from Daniel Nylander. Closes: bug#330610.

 -- Joel Rosdahl <joel@debian.org>  Sun,  9 Oct 2005 20:56:41 +0200

lyskom-elisp-client (0.48-4) unstable; urgency=low

  * Updated Vietnamese translation. Closes: bug#324223.
  * Updated French translation. Closes: bug#325137.

 -- Joel Rosdahl <joel@debian.org>  Fri,  2 Sep 2005 18:20:27 +0200

lyskom-elisp-client (0.48-3) unstable; urgency=low

  * Depend on "debconf | debconf-2.0" as requested by Joey Hess.
  * Updated to Standards-Version 3.6.2.

 -- Joel Rosdahl <joel@debian.org>  Thu, 11 Aug 2005 21:32:59 +0200

lyskom-elisp-client (0.48-2) unstable; urgency=low

  * Added Vietnamese debconf templates translation from Clytie Siddall.
    Closes: bug#312640.
  * Corrected typo in English debconf templates as suggested by Clytie
    Siddall. Closes: bug#312641.

 -- Joel Rosdahl <joel@debian.org>  Sat, 11 Jun 2005 10:49:53 +0200

lyskom-elisp-client (0.48-1) unstable; urgency=low

  * New upstream release.
  * Use dpatch for handling patches against upstream.

 -- Joel Rosdahl <joel@debian.org>  Sun, 23 Jan 2005 20:23:55 +0100

lyskom-elisp-client (0.47.1-7) unstable; urgency=low

  * Added Czech debconf templates translation. Closes: bug#289282.

 -- Joel Rosdahl <joel@debian.org>  Sun, 16 Jan 2005 21:58:48 +0100

lyskom-elisp-client (0.47.1-6) unstable; urgency=low

  * Added Japanese debconf templates translation. Closes: bug#260926.

 -- Joel Rosdahl <joel@debian.org>  Sun,  1 Aug 2004 15:10:56 +0200

lyskom-elisp-client (0.47.1-5) unstable; urgency=low

  * Added French debconf templates translation. Closes: bug#236725.

 -- Joel Rosdahl <joel@debian.org>  Thu,  1 Apr 2004 19:22:04 +0200

lyskom-elisp-client (0.47.1-4) unstable; urgency=low

  * Use gettext-based debconf templates. Closes: bug#233903.
  * Use debhelper compatibility level 4.

 -- Joel Rosdahl <joel@debian.org>  Fri, 20 Feb 2004 21:47:42 +0100

lyskom-elisp-client (0.47.1-3) unstable; urgency=low

  * Removed dependency on emacs20. Closes: bug#232768.
  * Updated to Standards-Version 3.6.1.

 -- Joel Rosdahl <joel@debian.org>  Mon, 16 Feb 2004 21:37:15 +0100

lyskom-elisp-client (0.47.1-2) unstable; urgency=low

  * Made Swedish keymap work in newer GNU Emacsen. Patch from Kalle
    Svensson. Closes: Bug#201736.
  * Updated to Standards-Version 3.5.10.

 -- Joel Rosdahl <joel@debian.org>  Thu, 17 Jul 2003 17:13:30 +0200

lyskom-elisp-client (0.47.1-1) unstable; urgency=low

  * New upstream release.

 -- Joel Rosdahl <joel@debian.org>  Wed, 23 Oct 2002 22:12:03 +0200

lyskom-elisp-client (0.47-1) unstable; urgency=low

  * New upstream release.

 -- Joel Rosdahl <joel@debian.org>  Sun,  8 Sep 2002 19:22:19 +0200

lyskom-elisp-client (0.46.1-3) unstable; urgency=low

  * Included com.lysator.liu.se as the default server.
  * Wrote a Swedish README file (README.debian.sv).
  * Fixed compilation warning in slow.el.

 -- Joel Rosdahl <joel@debian.org>  Sun,  6 Jan 2002 13:02:03 +0100

lyskom-elisp-client (0.46.1-2) unstable; urgency=low

  * Use section "net" instead of "misc".

 -- Joel Rosdahl <joel@debian.org>  Wed,  7 Nov 2001 22:05:25 +0100

lyskom-elisp-client (0.46.1-1) unstable; urgency=low

  * Initial version.  Closes: bug#115049.

 -- Joel Rosdahl <joel@debian.org>  Wed, 31 Oct 2001 23:03:19 +0100