Commit fb1ad25d authored by David Byers's avatar David Byers
Browse files

Fix bug 1645

parent 2fe457ae
......@@ -312,8 +312,7 @@ redhat-packages: $(PACKAGENAME)-src-$(CLIENTVERSION).tar.gz
-e "s/#REDHATCLIENTVERSION#/$(REDHATCLIENTVERSION)/" \
<$(PACKAGENAME).spec \
>$(RPMROOT)/SPECS/$(PACKAGENAME)-$(REDHATCLIENTVERSION).spec
rpm -ba $(RPMROOT)/SPECS/$(PACKAGENAME)-$(REDHATCLIENTVERSION).spec
rpmbuild -ba $(RPMROOT)/SPECS/$(PACKAGENAME)-$(REDHATCLIENTVERSION).spec
######################################################################
# Debian packages
......
......@@ -6,7 +6,7 @@ Requires: emacs >= 20.7
BuildRequires: emacs >= 20.7
BuildArchitectures: noarch
URL: http://www.lysator.liu.se/lyskom/
Source0: lyskom-elisp-client-all-%{version}.tar.bz2
Source0: lyskom-elisp-client-src-%{version}.tar.gz
License: GPL
Group: Applications/Internet
Prefix: /usr
......@@ -20,16 +20,16 @@ Lysator, see <URL:http://www.lysator.liu.se/>. For more information
on LysKOM, see <URL:http://www.lysator.liu.se/lyskom/>.
%prep
%setup -q -n lyskom-elisp-client-all-%{version}
%setup -q -n lyskom-elisp-client-src-%{version}
%build
emacs -batch -f batch-byte-compile lyskom-all-%{version}.el
make
%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp \
$RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/site-start.d
install -m 644 lyskom-all-%{version}.elc \
install -m 644 lyskom-%{version}.elc \
$RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/lyskom.elc
echo "(autoload 'lyskom \"lyskom\" \"Start LysKOM\" t)" > \
$RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/site-start.d/lyskom-init.el
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment