Commit 1fe332ad authored by Niels Möller's avatar Niels Möller

Update configure check to require GMP-6.0.0 or later.

parent 3170f3b4
2018-11-28 Niels Möller <nisse@lysator.liu.se>
* configure.ac: Update GMP check. Check for the function
mpn_sec_div_r, available since GMP-6.0.0.
* testsuite/rsa-encrypt-test.c (test_main): Fix allocation of
decrypted storage. Update test of rsa_decrypt, to allow clobbering
of all of the passed in message area.
......
......@@ -236,9 +236,9 @@ fi
# Checks for libraries
if test "x$enable_public_key" = "xyes" ; then
if test "x$enable_mini_gmp" = "xno" ; then
AC_CHECK_LIB(gmp, __gmpz_powm_sec,,
AC_CHECK_LIB(gmp, __gmpn_sec_div_r,,
[AC_MSG_WARN(
[GNU MP not found, or too old. GMP-5.0 or later is needed, see http://gmplib.org/.
[GNU MP not found, or too old. GMP-6.0 or later is needed, see https://gmplib.org/.
Support for public key algorithms will be unavailable.])]
enable_public_key=no)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment