Commit 87449457 authored by Niels Möller's avatar Niels Möller
Browse files

Updated version numbers, including LIBHOGWEED_MAJOR.

parent 2741b1c1
2014-05-15 Niels Möller <nisse@lysator.liu.se> 2014-05-15 Niels Möller <nisse@lysator.liu.se>
* NEWS: Updated with library version numbers.
* configure.ac (dummy-dep-files): Use simpler and more portable * configure.ac (dummy-dep-files): Use simpler and more portable
sed expression. Problem reported by Peter Eriksson. sed expression. Problem reported by Peter Eriksson.
(LIBHOGWEED_MAJOR): Bumped shared library version to 3.0.
(LIBHOGWEED_MINOR): Reset to zero. Also increased the package
version number to 3.0.
* getopt.c: Don't use gettext. * getopt.c: Don't use gettext.
......
...@@ -6,8 +6,10 @@ NEWS for the Nettle 3.0 release ...@@ -6,8 +6,10 @@ NEWS for the Nettle 3.0 release
It is *not* binary (ABI) compatible with earlier versions. It It is *not* binary (ABI) compatible with earlier versions. It
is mostly source-level (API) compatible, with a couple of is mostly source-level (API) compatible, with a couple of
incompatibilities noted below. incompatibilities noted below. The shared library names are
libnettle.so.5.0 and libhogweed.so.3.0, with sonames
libnettle.so.5 and libhogweed.so.3.
There may be some problems in the new interfaces and new There may be some problems in the new interfaces and new
features which really need incompatible fixes. It is likely features which really need incompatible fixes. It is likely
that there will be an update in the form of a 3.1 release in that there will be an update in the form of a 3.1 release in
...@@ -59,7 +61,7 @@ NEWS for the Nettle 3.0 release ...@@ -59,7 +61,7 @@ NEWS for the Nettle 3.0 release
INCOMPATIBLE CHANGE: dsa_generate_keypair also uses the new INCOMPATIBLE CHANGE: dsa_generate_keypair also uses the new
interface. dsa-compat.h declares a function interface. dsa-compat.h declares a function
dsa_compate_generate_keypair, implementing the old dsa_compat_generate_keypair, implementing the old
interface, and #defines dsa_generate_keypair to refer to interface, and #defines dsa_generate_keypair to refer to
this backwards compatible function. this backwards compatible function.
......
...@@ -2,7 +2,7 @@ dnl -*- mode: shell-script; sh-indentation: 2; -*- ...@@ -2,7 +2,7 @@ dnl -*- mode: shell-script; sh-indentation: 2; -*-
dnl Process this file with autoconf to produce a configure script. dnl Process this file with autoconf to produce a configure script.
AC_INIT([nettle], [2.8], [nettle-bugs@lists.lysator.liu.se]) AC_INIT([nettle], [3.0], [nettle-bugs@lists.lysator.liu.se])
AC_PREREQ(2.61) AC_PREREQ(2.61)
AC_CONFIG_SRCDIR([arcfour.c]) AC_CONFIG_SRCDIR([arcfour.c])
# Needed to stop autoconf from looking for files in parent directories. # Needed to stop autoconf from looking for files in parent directories.
...@@ -13,8 +13,8 @@ AC_CONFIG_HEADER([config.h]) ...@@ -13,8 +13,8 @@ AC_CONFIG_HEADER([config.h])
LIBNETTLE_MAJOR=5 LIBNETTLE_MAJOR=5
LIBNETTLE_MINOR=0 LIBNETTLE_MINOR=0
LIBHOGWEED_MAJOR=2 LIBHOGWEED_MAJOR=3
LIBHOGWEED_MINOR=4 LIBHOGWEED_MINOR=0
AC_CANONICAL_HOST AC_CANONICAL_HOST
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment