Commit 241dba16 authored by Andreas Kempe's avatar Andreas Kempe
Browse files

workstation: add nvidia_390 legacy driver class

Lain needs the legacy driver to function.
parent 1b7bcf10
#
class freebsd::workstation::nvidia_390 {
file_line { 'Enable linux support':
path => '/boot/loader.conf',
line => 'linux_load="YES"',
}
~> exec { '/sbin/kldload linux':
refreshonly => true,
}
-> package {
[
'nvidia-driver-390',
]:
ensure => installed,
}
-> file_line { 'Enable nvidia driver':
path => '/boot/loader.conf',
line => 'nvidia-modeset_load="YES"',
}
~> exec { '/sbin/kldload nvidia-modeset':
refreshonly => true,
}
file_line { 'Fix broken vt-terminals':
path => '/boot/loader.conf',
line => 'hw.vga.textmode=1',
}
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment